
Excel Treasure Maps
Discover Efficiency with Mapping Tables

MAPPING TABLES WEBINAR
OCTOBER 2020
excel-university.com



Table Of Contents

OVERVIEW

TRAVELING WITH SUMIFS

TRAVELING WITH POWER QUERY

TRAVELING WITH POWER PIVOT

1

2

5

9

18

RESOURCES 29



We’ll be discussing the treasure (efficiency) that can be achieved by using
mapping tables.

Let’s review the big picture before jumping into the mechanics.

Let’s say we export some data from a system and it looks something like this (we’ll
call this Point A):

Overview

And, let’s say we want to do something with the data that requires DIFFERENT
labels. For example, perhaps we would like to get the numbers into a report like
this (we’ll call it Point B):
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There are a couple of problems with this approach. First, each cell in report B
requires a custom formula--that is we can’t just fill the formula down. This
requires us to write a unique formula for each cell in the report. This isn’t very
efficient.

Second, this approach is fragile. Meaning if someone sorts the data in A, report B
will break. Or, if the order of the data changes next month when we paste
updated data, report B will break.

Rather than taking such a circuitous and dangerous route, we can use a map. A
map will help us get from point A to point B more efficiently. A map simply
defines the label translation between two tables, like this:

=B1+B2+B3

Then, the next cell in the report would point to different cells, perhaps like this:

=B4+B5

Since the LABELS between them are DIFFERENT, how do you get from Point A to
Point B?

The labels are different (AcctName versus the report labels), so we can’t simply
use a lookup function like VLOOKUP. One option is to write formulas that point to
the individual cells. Perhaps something like this:

I like to think of this as a treasure map, because it helps us discover the treasure
of efficiency!
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SUMIFS
Power Query
Power Pivot

There are many ways to implement such a map (aka, mapping table,
transformation table, or lookup table). In this series, we’ll look at three ways to
implement mapping tables. Specifically, we’ll discuss:

Implementation
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SUMIFS
SUMIFS is a conditional summing function. If you haven’t explored it much, feel
free to review these SUMIFS posts as I write about it quite a bit. From a high
level, it allows us to add up a column of numbers and only include the rows that
meet one or more conditions. The basic syntax is this:

=SUMIFS(sum_range, criteria_range1, criteria1, ...)

With this implementation, we would basically use SUMIFS to pull the numbers
from the source data into the map, and then again to pull the numbers from the
map into the final report. Although the text below is tiny, here is an image that
provides the general idea:

Now, let’s get to work. We’ll start by getting the numbers from the data source
into the map.
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Let’s say the data is stored in a table named Table1, like this:

We then create our basic map and store it in a table named Table2, like this:

We need to bring the amount values from Table1 into the map. We can use
SUMIFS to populate the map’s Amount column, like this:

=SUMIFS(Table1[Amount], Table1[AcctName], [@AcctName])

Data -> Map
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We hit Enter and bam:

With that done, now all we need to do is get the numbers from the map into the
report.

Map -> Report
Now that we have the values in our map (Table2), we need to get them into our
report:
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To pull the values from the map into the report, we’ll use SUMIFS. We can write
the following formula into J12:

=SUMIFS(Table2[Amount],Table2[FS Line],I12)

When we copy the formula down--bam:

Now, the nice thing is that when our data table is updated with different
transactions, they all flow through to the report automatically. When we have a
new account, we can add it to the mapping table. And if we have a new FS
Line, we can add it to the report.

This is one of many possible ways to implement a mapping table.
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Power Query
Overview
Let’s say we have a list of transactions in a CSV file, like this:

We would like to use the data to build a report like this:
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Load the tables
Merge
Build the report

We will accomplish this in three steps:

Let’s jump right in.

Since the transaction labels (Acct ID 1000, 1001, 1002, ...) and the report labels
(Cash and Cash Equivalents, Inventory, ...) are different, we need a way to
translate them. So, we create a mapping table, like this:

We could save the mapping table just about anywhere, for example a CSV file,
Excel workbook, or Access database. In this case, we’ll keep things simple and
save it to a CSV file.

Now, let’s see how to connect the dots with Power Query.

Narrative

Load the Tables

We need to load our transaction and mapping tables into Power Query. We’ll
start with the transaction table.
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Transactions
The first thing we need to do is to pull the transactions into Power Query. Since
our transactions are stored in a CSV file, we’ll use the Data > Get Data > From
File > From Text/CSV and then browse to our transactions file.

Note: If your transactions are elsewhere, you would use the corresponding Get
Data option.

We can see a preview like this:

Since our data is clean, there are no transformations needed and we can expand
the Load button by clicking the down arrow and selecting Load To. In the
resulting dialog, we select Only Create Connection, like this:

11



Note: if your data needs to be cleaned up, you would click the Transform button
and make any transformations needed before loading the query to a Connection
Only Query.

Since we loaded it to a connection-only query, we do not see the results in an
Excel table...yet. Which is perfect. Now that the transactions are in Power Query,
it is time to pull the Mapping Table into Power Query.

Map
We basically perform the same steps to retrieve the mapping table. Since our
map is stored in a CSV, we can use the Get Data > From File > From Text/CSV
and browse to the map file. We see the preview and once again, Load To a
connection-only query.

At this point, we should have the data and map queries in our workbook, and we
should see them in the Queries & Connection pane, like this:

With our data and map queries in place, it is time to combine them.
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To combine these two queries, we use the Get Data > Combine > Merge
command. In the resulting Merge dialog, we select our data query from the top
drop down and our map query from the bottom drop down, like this:

Merge

Now we need to tell Power Query how these two tables are related. If you are
familiar with VLOOKUP, it is like identifying the lookup value.
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In our case, the lookup column is AcctID. So we select both AcctID columns, like
this:

We click OK and see the results in the Power Query editor, like this:
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We click the expand button on the right side of the map column header, and
select the columns we want to display … in our case, the FS Line column. The
results look like this:

With this complete, we can use the Home > Close & Load To command, and
select our destination in the resulting dialog. In our case, we’ll load the results to
a Table in a new worksheet:
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We click OK, and the resulting table (in this case, named Merge1) is displayed in
our worksheet:

Now all that remains is to build our report.

Report
We have options for which type of report to use to summarize the data. In this
post, we’ll use a formula-based report and revisit the SUMIFS function.

Here is our report layout:
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We can write the following formula into cell G12:

=SUMIFS(Merge1[Amount],Merge1[FS Line],F12)

And then fill that formula down--bam:

Yay--we did it!

To update the report in future periods, we simply right-click the
green results table (eg, Merge1) and select Refresh. Power
Query will retrieve the updated transactions file as well as any
changes made to the map. Provided there are no new FS Lines
and that any new accounts are added to the map, we are good
to go.
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Power Pivot

We have a bunch of data stored in a CSV file, like this:

Overview

We’d like to use the data to build a report that looks like this:
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We’ll once again use Power Query to retrieve the tables, but this time, we’ll load
them to the data model.

Rather than rehash the detailed Power Query, I’ll just provide a quick summary.
Feel free to check out the previous post if you’d like to reference the detailed
steps.

Just like before, we use the Data > Get Data > From File > From Text/CSV
command and browse to the data file. But, unlike before, when we Load To a
connection-only query, we need to check the Add this data to the Data Model
checkbox, like this:

Since the labels between the data (1000, 1001, 1002,...) and the report (Cash and
Cash Equivalents,...) are different, we create a mapping table that includes the
report lines and groups we will need, like this:

Let’s see how we can use Power Pivot to connect the dots.

Narrative

Retrieve tables
Relate tables
PivotTable report

We’ll tackle this in the following steps:

Let’s get to it.

Retreive Tables
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Checking the checkbox enables us to relate the data table to the mapping
table in Power Pivot, which we’ll do shortly. But, before we do, we need to grab
the mapping table.

So, again, we use Power Query to retrieve the mapping table and we Load To
a connection-only query and again check the Add this data to the Data Model
checkbox.

Now that we have retrieved the data and map, it is time to relate them using
Power Pivot.

Relate Tables
Now it is time to relate the data and mapping tables. That is, we need to tell
Excel how the two tables are related to each other. Once again, our tables are
related via the AcctID columns.

If you haven’t used Power Pivot before, you’ll want to click the manage data
model command on the Data tab, which looks like this:
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The first time you click this button, you’ll be promoted to enable Power Pivot.
Once you do, you should have the Power Pivot tab at the top of your Excel
window.

Going forward, you can open Power Pivot by clicking that command on the Data
tab, or you can click the Manage command on the Power Pivot tab which looks
like this:

With the Power Pivot window open, we click the Home > Diagram View
command, and we can then see the data and map tables:

To define the relationship, we simply click and drag the AcctID column from the
data table to the AcctID column in the map. The relationship is illustrated like
this:

Now that we have defined the relationship, we are ready to create our summary
report. We can close Power Pivot and head back to Excel.
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PivotTable Report
In Excel, we use the Insert > PivotTable command to open the Create
PivotTable dialog:

For the data source, we will Use this workbook’s Data Model. We can place the
PivotTable on a New or Existing sheet as desired.

We notice that we have the data and map tables listed in our PivotTable Fields
pane. When we expand both tables, we see the columns, like this:

22



Let’s modify the report layout to only display Assets. (Later, we can create
another PivotTable to show Liabilities & Equity.)

Let’s start by filtering out Equity and Liabilities. There are several ways to
accomplish this … one way is to right-click each and select Filter > Hide. So,
right-click Equity, Filter > Hide. Right-click Liabilities, Filter > Hide. Our updated
report looks like this:

We check the Sub, FS Line, and Amount fields (in that order), and our PivotTable
looks a bit like this:
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Next, we can click and drag the FS Labels to order them as desired:

Next, we turn on subtotals by right-clicking the Current cell and selecting
Subtotal from the shortcut menu. Our updated report looks like this:
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With our basic report structure looking pretty good, it is all a matter of cosmetics
at this point.

We can use the PivotTable Styles gallery to pick a style we like, such as
PivotTable White Medium 11:

We can insert a blank row between groups by clicking the PivotTable Design >
Blank Rows > Insert Blank Line After Each Item command:
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Toggle off the +/- Buttons and the Field Headers:

We can change the number formats by right-clicking any value and selecting
Number Format:
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We can type in new labels for the subtotal or header cells if desired:

We can then do the same thing to create the Liabilities & Equity side of the
report:

Yay--I think we got it! 27



The nice thing about this approach is that PivotTables are dynamic
so if there are new assets in the mapping table next period, the
report will automatically expand to display them when the report
is refreshed.

I hope this Treasure Maps series has been helpful--and I hope mapping
tables help you discover the treasure of efficiency in your work!

Although this series has focused on one illustration for mapping tables (a
financial statement), please note that this same technique can be applied in
other situations when the labels are different between two tables. For example,
you download the banking activity and need to get the activity descriptions
mapped to accounts, or you have an Expensify download that needs to
mapped to expense codes, or you have inventory skus that need to be mapped
to product codes in your accounting system, and so on. Whenever labels are
different between two places, mapping tables can be an efficient way to get
from point A to point B.
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