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"The greatest
geniuses sometimes

accomplish more
when they work less."

Leonardo Da Vinci



Use a Get & Transform Query to
Transpose Values
I get a kick out of using Get & Transform queries to accomplish tasks that we previously
performed with other methods. It is clear that the Get & Transform commands provide new ways
to solve old problem. Here, I’ll demonstrate how we can use a Get & Transform query to
transpose values.

Objective
Before we get too far, let’s just be sure we are on the same page. Sometimes, data comes to us in
one format, but, we need it in another. For example, the data below displays regions in rows and
items in columns.

 

 

But, for our report, we need regions in columns and items in rows. We need to transpose the
orientation, as shown below. 

 

 



In a blog post, I demonstrated three ways to accomplish this task, including Paste Special, using
formulas, and using a PivotTable. In this section, we’ll accomplish it with a Get & Transform query. 

This transformation is simple with a Get & Transform query, and the best part is that it is easy to
refresh in subsequent periods. We’ll accomplish this task with the following steps. 

 

Note: The steps below are presented with Excel for Windows 2016. If you are using a different
version of Excel, please note that the features presented may not be available or you may need to
download and install the Power Query Add-in. 

 

Load the source

To load the source, we select the entire range of data, and select Data > From Table. If the data is
already stored in a table or a name, then, the Query Editor will open immediately. If not, you’ll first
see the Create Table dialog asking you to confirm that you want to convert the ordinary range into
a table (which you do).

The query editor opens, and provides a preview as shown below.

https://www.excel-university.com/transpose-values-and-formulas-in-excel/


 

With the data source loaded into the editor, it is time for the next step.

Perform the transformation

This step is really complex 

Just kidding, it is really easy  We just need to click three buttons.

First button: Since the values we need were actually used as column headers, we need to click
the Use Headers As First Row command (which is located on the Home > Use First Row As
Headers drop down, and the Transpose > Use First Row As Headers drop down). This will
“demote” the header labels and push them down into the data as values.

Second button: Now, we just click the Transform > Transpose ribbon command. And just like
that, the data is transposed.

Third button: Now, we just need to tell Excel to use the first row of values as the column labels.
We basically need to “promote” the values. So, we click the Use First Row As Headers button.
The updated query, with items in rows and regions in columns, is shown below.

Now, we just need to get the data back to Excel.



Return the data to Excel

To return the query results to Excel, we just click the Home > Close & Load command. And
bam…our transposed data is back in Excel.

But, Jeff…hang on man…this is way more complex than doing a copy/paste special transpose.
Well, if this were a one-time task, I am right there with you. Let’s just manually copy/paste, get er
done, and move on with our life. But, if we are doing this on a recurring basis, daily, weekly,
monthly…then…the benefit of this approach becomes clear. Next period, we simply right-click the
results table, and select Refresh. The results table is immediately update to include any changes
to the original table.

Additional Resources
Sample Excel File

https://www.excel-university.com/wp-content/uploads/TransposeGT.xlsx


Unpivot Excel Data 

Excel easily summarizes flat, tabular data. When data is stored in a crosstab style format instead,
Excel users have to spend a bit of time preparing the data for use. There are many ways to
accomplish just about any Excel task, but I’ll demonstrate how to quickly unpivot the data. 

Before we dig into the mechanics, let’s be sure we are clear
about the data formats and our objective. 
 

Here is an example of flat, tabular data:

 

https://www.excel-university.com/unpivot-excel-data/


 

Here is an example of the same data stored in a crosstab style format: 

We can easily convert tabular data into a crosstab format using a PivotTable. But here, we want to
do the opposite. We want to unpivot the data, converting it from a crosstab format into a tabular
format.

Note: please note that unpivoting the data is not the same as transposing it. Transposing the data
would place departments in rows and accounts in columns. If you need to transpose instead of
unpivot, check out this Excel University blog post instead.

Here is another example that shows students and the trips they have attended.

And one more example that tracks who is assigned to various tasks.

https://www.excel-university.com/transpose-values-and-formulas-in-excel/


Now that we have our bearings and can visually see our objective, let’s work through the details.

Unpivot
The unpivot command is available without any additional downloads in Excel 2016 for Windows. If
you are using a different version, you may need to first download the free Power Query add-in
from the Microsoft site. At the time I’m writing this, it is available from the link below.

The four easy steps we’ll use to unpivot our crosstab data are:

We’ll take them one at a time.

 

Store the crosstab data in a table 

First, we need to ensure that our crosstab data is stored in a table. If it already is, you can skip
this step. Our data isn’t stored in a table, and it currently looks like this.

To convert it into a table, we select any cell in the data range and click the Insert > Table
command. Now, it is stored in a table and looks like this.

Hey, that was pretty easy. Let’s move to the next step.

 



 
 
Get & Transform From Table
 

The next step is to use the Get & Transform From Table command. Again, this is built-
in beginning with Excel 2016 for Windows. If you have a different version, you’ll want to download
and install Power Query using the link below, and note that the navigation may be slightly different
from the screenshots presented below.

First, we select any cell in the table. Then, we click the following Ribbon command located in the
Get & Transform group.

This opens the Query Editor, as shown below.

Hey, that was pretty easy…let’s take the next step.

 
Unpivot



Before we use the unpivot command, we first need to tell Excel which columns we’d like to
unpivot. To do this, we can select the first column we want to unpivot, hold down the Shift key, and
then click the last column. The results are shown below.

 

Note: if you would like to undo a step in the Query Editor, you click the x in the Applied Steps list
box.

Now that we have identified which columns to unpivot, we can use the unpivot command. The
unpivot command is located on the Transform tab. Since the Ribbon dynamically sizes itself
based on the dialog size, you may see the unpivot columns command with a text label, like this:

Or, it may appear without a text label, like this:



Just click the command icon, and bam, Excel unpivots the data, as shown below.

Hey, that was pretty easy! The final step is to load the data back into our workbook.

 
Load
With the data unpivoted, we just need to get it back to our workbook. To do so, we use the Close
& Load command on the Home tab. Excel drops the unpivoted data back into our workbook, as
shown below.



That was easy!

The unpivot command is but one of the many powerful capabilities in the Query Editor dialog. If
you retrieve data from external sources and perform data transformations often, you’ll definitely
want to investigate the additional commands.

https://www.microsoft.com/en-us/download/details.aspx?id=39379 
Get a quick email notice when a new Excel article is available

https://www.microsoft.com/en-us/download/details.aspx?id=39379


 
Get & Transform: An Alternative to
Reformat Macros 

Excel 2016 includes a set of features called Get & Transform. In previous versions of Excel, these
capabilities were included in the Power Query Add-In. In this section, we’ll see how a Get &
Transform Query can be used as an alternative to a VBA macro.

Overview
Here is the scenario. We export data out of some system, and save it in a CSV file. We then need
to prepare it for use. Perhaps to import into another system, or perhaps to use in a PivotTable or
formula-based report. We basically need to clean up the data, remove some columns, change the
headers, and so on.

Back in the old days, we could automate such a task with a VBA macro that reformatted the data.
Yes, it was difficult to write initially, but, it felt great when we got it working. And life was good, until
something in the data changed….like a new column. Some type of change like this could break
the macro. Then, we would need to crack open the Visual Basic Editor and troubleshoot. It took
some time to figure out how to resolve the issue, but, it felt great once we got it working again.
Until something else changed. Argh.

https://www.excel-university.com/get-transform-an-alternative-to-reformat-macros/


The good news is that a Get & Transform Query is an easy alternative to building such a VBA
macro. Best of all, modifications are easy to make when something changes.

Objective
For the purposes of this post, here is what we’d like to automate without a VBA macro:

Retrieve data into Excel from a CSV file
Put all email addresses into lower case
Put all state codes into UPPER case
Capitalize the first word of all other names
Remove a column
Order the columns
Change the column headers
Filter out certain rows

And, we want to be able to refresh next month with a single click, or better yet, no click. 

Sound like a tall order? It is easy these days. All we need is a Get & Transform Query.

Note: if you are working along in a version of Excel other than Excel 2016 for Windows, you may
not have the Get & Transform tools, or, you may need to download the Power Query add-in.

Details
Let’s just jump right in. We’ll basically take the steps in the same order as the bullets above.

Retrieve CSV data

We’ll retrieve orders from a CSV file that was exported from our ecommerce system. But, if you
are working with data in some other format, you’ll be glad to know that Get & Transform works
with tons of data sources.

Note: if you’d like to work along with these steps, feel free to download the sample data file using
the link at the end of this section.

To begin, we create a new workbook and then select the following Ribbon command:

Data > New Query > From File > From CSV

This opens the Import Data dialog, where we simply browse to and select the CSV file. Once we
do, we are presented with a dialog that allows us to preview a sample of the data, as shown
below. 



Since our data needs to be cleaned up a bit, we’ll click the Edit button. This opens the Query
Editor dialog, as shown below.

Now, it is time to clean up, or transform, our data.



Before we jump in, it is important to realize that the following transformations are done inside of
Excel, and are not being made to the source data. The source data, in our case the CSV file, is
left unaltered. The preview just shows what our data will look like when it arrives in Excel.

Lower case

The first task is to clean up the email address column. Since the customers enter their information
online, the email addresses are inconsistent. Some customers enter their address in all caps
(JOHN@GMAIL.COM), some in lower case (john@gmail.com), and some in proper case
(John@Gmail.Com). Since we like our data to be nice and tidy, we’ll convert all email addresses
into lower case. To do so, we begin by selecting the email column as shown below.

To transform into lower case, we can either right-click the column header and select Transform >
lowercase, or, click the following Ribbon icon:

Text Columns > Format > lowercase

Either way, Excel updates the data as shown below.



Note: to undo a step in the Query Editor, you click the corresponding x in the Applied Steps list
box.

Upper case 

Also sloppy is the State code. We have upper, lower, and mixed case. So, we right-click the State
column header, and transform to UPPERCASE. The results are shown below.

Capitalize

Actually, the City, StreetAddress, GiveName, and Surname columns are all sloppy as well. So, we
simply transform each of them to Capitalize Each Word. The clean results are shown below.



Remove columns

We don’t need the MiddleName column, so, we’ll remove it. We can do it with the Remove
Columns Ribbon command, or, we can simply right-click the column header and select Remove.

The update is shown below.

 

 



Order the columns

We need to change the order of the columns. To do so, we can just click-and-drag the column
headers, or, right-click a column header and use the Move option.

In our case, we need the email address column to be the first column, so, we just right-click the
Email column header, and select Move > To Beginning.

The update is shown below.

Change column headers

Now we’d like to update the column headers. Doing so is straightforward. We can right-click the
column header and select Rename, or, use the following Ribbon command:

Transform > Rename

We update the GivenName header to First Name, Surname to Last Name, and StreetAddress to
Address. These updates are shown below. 



Filter

Finally, we want to exclude any rows where the amount is zero. To do this, we simply select the
drop-down in the Amount column header, and select Number Filters > Does Not Equal…0.

The update is shown below.

With our data cleaned up and looking good, we are ready to bring it into Excel.



Load

To return the data to Excel, we use the Close & Load command. If we have a specific destination
in mind, such as existing worksheet, we can click Close & Load To. If we just want to pull the data
into a new worksheet, we can click Close & Load. In our case, we click Close & Load, and bam…
the transformed data flows into an Excel table as shown below.

And…we didn’t use a single line of VBA code to do it!

Updating
What about updating next period? Well, it is easy. There are actually two issues to consider. The
first is updating the Excel file with newly exported CSV data. The second is updating the query to
perform different steps. Let’s talk about both issues.

New Data

When you export new data next period, if you save it in the same folder and with the same file
name as the old CSV, all you need to do in Excel is right-click any data cell and select Refresh, or,
use the following Ribbon command:

Query Tools > Refresh

That will update the table with a single click. Can you have Excel update the data without any
clicks? Yes, you can ask Excel to refresh the query automatically when you open the workbook.
To do this, right-click any data cell, and select Table > External Data Properties. In the resulting
External Data Properties dialog, click the little Connection Properties icon to the right of the Name
field. In the resulting Connection Properties dialog, check the Refresh data when opening the file
checkbox, as shown below. 



Now, you just export the new CSV file, save it to the same folder with the same name, and then
open your Excel file. Excel will automatically apply the transformations and retrieve the updated
data into the table. Wow.

If you use a different file name, then you’ll need to edit the query. Which also happens to be how
you add, edit, or delete steps. So, let’s talk about how to edit the query.

Edit the Query

To edit the query, you can select any data cell and then double-click the query in the Workbook
Queries panel, or, click the following Ribbon command:

 Query Tools > Edit

 

This will display the Query Editor dialog. Here, you can change all kinds of things. To edit an
existing step, click the gear in the Applied Step panel. For example, to change the data source,
click the gear on the Source applied step. To change the order of a step, right-click it and select
Move Up or Move Down.

To delete a step, click the x in the Applied Step dialog.

To add a new step, select the last step and then perform the task. To add a step in the middle of
the current steps, select any step and then perform the task. Be careful when inserting an
intermediate step because it may affect subsequent steps and break your query.



Conclusion
If you haven’t yet played with the Get & Transform features, they are worth digging in to. I don’t
want to sound overly dramatic here, but, they are a game changer. They provide us new ways to
solve old issues and allow us to easily accomplish tasks that were previously really hard or
impractical. I have a series of Get & Transform blog posts topics lined up that will demonstrate
some of the capabilities. 

Additional Resources
Data

 

https://www.excel-university.com/wp-content/uploads/Data.csv


 
An Alternative to Copy Paste Append 

Let’s say you have several data tables, and you need to combine them into a single table. One
option would be to copy and paste to append them. But, depending on how many data tables
there are, this type of manual process can be tedious. In this section, we’ll use a Get & Transform
query as an alternative to the copy/paste append method.

 
Objective
Each period, we receive several csv files that need to be combined vertically to create one great
big data table. The first file contains the employees of DeptA, and looks like this:

The remaining csv files contain similar employee lists with the same columns and structure.

https://www.excel-university.com/get-transform-an-alternative-to-copy-paste-append/


We need to combine these files and stack the employees vertically into one big table in a single
Excel workbook. We could opt to do this the manual (slow) way, and just open each csv file,
select the employees, copy, flip to the destination file, and paste append. But, why would we want
to do it that way when we can do it the fast way? Well, unless we have a lot of extra time on our
hands, we’ll use a Get & Transform query. Here’s how.

Details
Our task is surprisingly fast and easy. In fact, the first time I saw this my jaw literally dropped. (But
then again, I’m an Excel nerd.) There are three steps:

New query
Combine binaries
Load

Let’s do this. 

Note: The steps below are presented with Excel for Windows 2016. If you are using a different
version of Excel, please note that the features presented may not be available or you may need to
download and install the Power Query Add-in.

New query
First we need to create a new query. In a blank workbook, we use the following Get & Transform
command.

New Query > From File > From Folder

Excel displays the Folder dialog, and we simply browse to the folder that contains our csv files, as
shown below. 

Note: for this demonstration, we assume that the folder only contains the csv files we want to
combine. If not, you’ll need to take extra steps to filter the file list accordingly.

When we click OK, we see a list of the files in the folder, as shown below.



Now, we don’t want to return the file list to Excel, so we don’t click Load, we click Edit. This
launches the Query Editor as shown below.

Well, believe it or not, the hard part is already done! Let’s head into the next step.

Combine binaries 
Next, we need to tell Excel to combine the files. We can do this either by clicking the combine
binaries icon in the upper right of the Content column header, or, use the following ribbon
command:



Home > Combine > Combine Binaries

Excel combines the files, and provides a preview, as shown below.

Wait, what!? Yep. The files have been combined, and all employees are now in a single vertical
list. Oh…I just heard your jaw drop!

 

Load
To get these back into Excel, we simply use the Close & Load command. The results table
appears in Excel, as shown below.

Now…wasn’t that faster (and more fun) than using copy/paste?
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