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A goal is not always meant to be
achieved. Often it serves simply as
something to aim at. 
 

Bruce Lee
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Get & Transform: An Alternative

to Copy Paste Append 

Let’s say you have several data tables, and you need to combine them into a single
table. One option would be to copy and paste to append them. But, depending on
how many data tables there are, this type of manual process can be tedious. In this
post, we’ll use a Get & Transform query as an alternative to the copy/paste append
method.

Objective
Each period, we receive several csv �les that need to be combined vertically to
create one great big data table. The �rst �le contains the employees of DeptA, and
looks like this:

The remaining csv �les contain similar employee lists with the same columns and
structure.
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We need to combine these �les and stack the employees vertically into one big
table in a single Excel workbook. We could opt to do this the manual (slow) way,
and just open each csv �le, select the employees, copy, �ip to the destination �le,
and paste append. But, why would we want to do it that way when we can do it
the fast way? Well, unless we have a lot of extra time on our hands, we’ll use a Get
& Transform query. Here’s how.

Details
Our task is surprisingly fast and easy. In fact, the �rst time I saw this my jaw
literally dropped. (But then again, I’m an Excel nerd.) There are three steps:

New query
Combine binaries
Load

Let’s do this.

Note: The steps below are presented with Excel for Windows 2016. If you are using
a different version of Excel, please note that the features presented may not be
available or you may need to download and install the Power Query Add-in.

New query
First we need to create a new query. In a blank workbook, we use the following Get
& Transform command.

New Query > From File > From Folder

Excel displays the Folder dialog, and we simply browse to the folder that contains
our csv �les, as shown below.
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Note: for this demonstration, we assume that the folder only contains the csv �les
we want to combine. If not, you’ll need to take extra steps to �lter the �le list
accordingly.

When we click OK, we see a list of the �les in the folder, as shown below.

Now, we don’t want to return the �le list to Excel, so we don’t click Load, we click
Edit. This launches the Query Editor as shown below.
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Well, believe it or not, the hard part is already done! Let’s head into the next step.

Combine binaries
Next, we need to tell Excel to combine the �les. We can do this either by clicking the
combine binaries icon in the upper right of the Content column header, or, use the
following ribbon command:

Home > Combine > Combine Binaries

Excel combines the �les, and provides a preview, as shown below.

Wait, what!? Yep. The �les have been combined, and all employees are now in a
single vertical list. Oh…I just heard your jaw drop!

Load
To get these back into Excel, we simply use the Close & Load command. The results
table appears in Excel, as shown below.
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Now…wasn’t that faster (and more fun) than using copy/paste?

Resources
Zip �le that contains the three csv �les used above in case you’d like to try: Extracts
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How to Build a PivotTable with

the Data Model 

Traditional PivotTables are an incredible feature of Excel, but, they are not without
limits. Many of the typical restrictions are removed when you use the data model
rather than a single Excel table. If you’d like to learn how to build a PivotTable using
the data model, and learn what the data model is, strap in…this will be fun.

Overview
Before we get too far, let’s jump up to 30,000 feet. For starters, what exactly is the
data model? The data model provides a way to organize tables and formulas that
can be used in a PivotTable. The data model comes with Excel 2016+ for Windows,
and was formerly available as the Power Pivot add-in. The remainder of this article
is presented with Excel 2016 for Windows.
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Building a PivotTable from the data model rather than a single Excel table offers
numerous advantages. Here are just a few to get us started.

We can create a PivotTable that uses various �elds from multiple tables.
The formulas we can write far surpass those available in a traditional PivotTable. A
language called DAX is used to write the formulas, and it provides many powerful
functions.
We can pick and choose rows and columns using named sets.
We can directly connect to the data source (instead having to copy/paste data into a
worksheet), use a Get & Transform query (to clean the data before it arrives), and connect
to multiple data sources (eg, a csv �le, a database table, and an Excel workbook) in a single
model.
Once built, we can just Refresh the report in subsequent periods (rather than having to go
through the whole export, clean, import, and merge into a single data table process).

And, these are just a few of the highlights.

Details
Our plan is to create a PivotTable from two tables. One data table has the
transactions, and another table stores the chart of accounts. Historically, we would
need to use VLOOKUP or something to �rst combine these tables into a single table
to use with a traditional PivotTable. Here, we’ll use the data model. We’ll walk
through these steps together:

Enable the data model
Import the data tables
De�ne relationships
Build the PivotTable

Let’s get started.

Enable the data model
First, we’ll need to enable the Power Pivot add-in. If you have Excel 2016+ for
Windows, just click the Data > Manage Data Model ribbon command as shown
below:

Note: depending on your screen size, you may see the icon only and not the label.

Clicking it the �rst time asks you to enable the add-ins:



Once you click Enable, you are all set and should see a Power Pivot ribbon tab. Yay!

Note: If you are on an earlier version of Excel for Windows, you’ll need to download
and install the free Power Pivot add-in from the Microsoft website and follow the
installation instructions for your version of Excel.

Import the data tables
Next, we import the data tables. In our case, we have some transactions stored in a
DataTable workbook. The transactions have the account number but not the
related account name. Fortunately, we have a little something called a chart of
accounts, which is stored in the LookupTable workbook.

The step to import data tables will vary depending on where your source data is. To
get started, click the Power Pivot > Manage ribbon command. This opens the
Power Pivot window, shown below.

 

Use the Get External Data command to point to the underlying data source.



In our case, the data is in a couple of Excel �les, so, we use the Get External Data >
From Other Sources option, and then select Excel File in the resulting dialog. We
Browse to the desired workbook and check Use �rst row as column headers. We
�nish the wizard and bam, the data is loaded into our data model, as shown below.

 

Note: if you are creating a data model inside the workbook that has the tables, you
can use the Power Pivot > Add to Data Model command instead. 

Next, we do the same thing to pull data from the LookupTable Excel �le. The
updated Power Pivot window is shown below.



With our data loaded into the data model, we need to tell Excel how the tables are
related (which columns are common between the tables) by de�ning the
relationships.

De�ne relationships
There are several ways to de�ne relationships, but my favorite way is to use the
visual diagram view. To toggle away from Data View (shown above), and Diagram
view (shown below), simply click the Home > Diagram View command. We’ll now
see the tables with the column names (instead of seeing the data transactions), as
shown below.



To de�ne the relationship, click the column name from the DataTable and drag to
the related column in the LookupTable. In our case, we are relating the DataTable’s
AcctNum column to the LookupTable’s AcctNum column. Excel displays the
relationship as shown below.

 



With our relationship de�ned, we can now build the PivotTable.

 
Build the PivotTable
In the Power Pivot window, we just click the PivotTable > PivotTable command and
select either a New Worksheet or an Existing Worksheet in the resulting Create
PivotTable dialog. Once we click OK, bam, we see the familiar PivotTable �eld
panel.

But, wait a sec … on closer inspection, it looks a little different from the traditional
�eld panel. We typically see a list of �elds that we can insert into the report. But
now, we actually see the tables, and can expand each table to view the �elds in
each as shown below.

And, yes, we can pick �elds from either or both of the tables for our report. For
example, we want the AcctName from the LookupTable in Rows, and the Amount
�eld from the DataTable as Values. And, bam … done!



Now, if your �rst reaction is that it would have been easier to just use VLOOKUP to
create a single table, I totally understand. But, here’s the thing. This example is
fairly simple because it includes but a single lookup table. The data model supports
numerous lookup tables, for example, a chart of accounts, and calendar table, a
department list, and so on. Plus, in addition to having multiple lookup tables in your
data model, you can also have multiple data tables.

Plus, there is the issue of updating our report on an ongoing basis. Since we aren’t
using VLOOKUP to retrieve related values, we don’t need to babysit a bunch of
lookup formulas each month. As the external data source is updated, perhaps for a
new account or new transactions, we can just Refresh and the new data �ows into
the report. As you can imagine, this opens up many interesting possibilities and can
help save time in our recurring-use workbooks

Sample Files:

DataTable.xlsx
LookupTable.xlsx
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PivotTable from Many CSV Files 

In this section, we’ll summarize data from multiple CSV �les with a PivotTable.
Speci�cally, we’ll use a Get & Transform query (Power Query) to retrieve and
prepare data from numerous CSV �les. Then, we’ll send the query results into the
data model (Power Pivot). Then, we’ll build our summary report using a PivotTable
based on the data model. And, it will be easy! And fun

Objective
Before we get too far, let’s just con�rm our goal. We have 3 CSV �les exported from
our accounting system, one for Jan, Feb, and Mar. Here is a sample:

Note that the extract has account numbers, but no account names. And, there are
dept numbers but no names. Our summary report needs to display the account and
department names, as shown below:
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Detailed Steps
We’ll prepare our report using these steps:

Retrieve with a Get & Transform Query
Relate Tables in the Data Model
Summarize with a PivotTable

We’ll walk through each step one by one.

Note: the steps below were performed with Excel 2016 for Windows and uses
features that are not available in all versions of Excel, namely, Get & Transform
queries (Power Query) and the data model (Power Pivot). In addition, the
navigation and dialog boxes may differ from the version of Excel you may be using
right now. Please visit the Microsoft website for more information about these
features, how to enable them, and which versions include them.

 

Retrieve with a Get & Transform Query
First, we need to pull the data from all the CSV �les. To do so, we select the Data >
Get Data > From File > From Folder command. We browse to the folder that
contains the CSV �les, and click OK. Excel displays a list of �les found in the folder,
and since we want to import all of them, we just click the Combine button and
select Combine & Load To from the dialog shown below.
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Note: if we wanted to exclude some �les, we would click Edit and then apply a �lter
to remove other �le types (such as PDF).

In the resulting Combine Files dialog, we just click OK.

Then, we tell Excel that we want to add the data to the data model and create a
connection only, as shown below.

Click OK, and now we have the data from the various CSV �les loaded into the data
model. Nice!
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Relate Tables in the Data Model
Now it is time to bring in the account names and department names. We have the
chart of accounts stored in an Excel table, as shown below.

To add this to the data model, we select any cell in the Table and select Power Pivot
> Add to Data Model.

Note: if the chart of accounts is stored somewhere else, such as a database or csv
�le, we would use the Power Pivot window and use the corresponding Get External
Data command.

Then, we repeat these steps to load the Departments Table into the data model.

To tell Excel how these tables are related, we need to de�ne the relationships. We
do so by clicking the Power Pivot > Manage command. In the Power Pivot window,
we click Home > Diagram View. We can see our three tables, and they have no
relationships de�ned, as shown below.
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To de�ne the relationships, we just click-and-drag the AcctID �eld from the
DataFiles table to the related AcctID �eld in the Accounts table. Then, we drag-
and-drop the DeptID �eld from the DataFiles table to the corresponding DeptID
�eld in the Departments table. Now, the tables are related, as shown below.

Now, all we need to do is summarize the data with a PivotTable.
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Summarize with a PivotTable
In Excel, we click the Insert > PivotTable command. We ensure that the Use this
workbook’s Data Model is selected, as shown below, and click OK.

Now, we are free to build our report in any desired structure or shape.

For example, we can insert the DeptName �eld from the Departments table into the
Rows layout area. Then, insert the AcctName �eld from the Accounts table into the
Rows layout area. And �nally, insert the Amount �eld from the DataFiles table into
the Values area.

Our basic report is done, and we can apply any cosmetics we’d like. For example,
we could use the PivotTable Tools > Report Layout > Tabular command and the
Subtotals > Show All Subtotals at Bottom of Group to create the report shown
below.
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And, we did it! And look, all we did was click a few commands … we didn’t need to
write a single formula … wow!

Oh yeah, and the best part is that next month, we can simply add the April extract
to the data folder, and click Data > Refresh All to update our report

If you’d like to practice, I’ve provided the sample �les below.

Note: Be sure to unzip them before you get started.

Sample �les: PQ2PP.zip
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